If somebody like the post and its helpful in your work then, add comments.

Monday, October 29, 2012

The forefront identity manager service service on local computer started and then stopped : SharePoint 2010 user profile issue

When we create user profile service application, then some times the User profile Synchronization services does start or run. The common scenarios the farm admin and domain admin are same. So, user profile synchronization does not run under the same account. From my research or we can say finding, when we do new installation of the SharePoint in new server, most of the time the service does not run, we just wait for long hours, and it stat is like starting. Seriously it wasted my lot of time, just sitting at my screen and waiting to start.

The main reason of the that is, we have create a new service account say “sp_userprofiles” in managed account of the Active Directory section.


And give the following permissions.


Now we have create one Delegate Control for created user.


Click on Next

On the Users or Groups page, click Add

Type the name of the synchronization account (farikam\sp_userprofiles), and then click OK.


On the Tasks to Delegate page, select create a custom task to delegate, and then click Next.


On the Active Directory Object Type page, select This folder, existing objects in this folder, and creation of new objects in this folder, and then click Next.


On the Permissions page, in the Permissions box, Select Replicating Directory Changes (select Replicate Directory Changes on Windows Server 2003), and then click Next.


Click Finish.


Create User profile Service Application.

Run the services from Central Admin(User Profile Service and User Profile Synchronization Service )


Check the services.msc in the system


Both service are now running(Do not run or edit the properties of the service manually)

Enjoy SharePoint Smile